bildwelt
E2E FORUM
E2E Bridge E2E Commerce

Stopping/starting services with Curl.exe

E2E Forum Modeling & Development Stopping/starting services with Curl.exe

This topic contains 3 replies, has 2 voices, and was last updated by  e2eforum-admin 1 year, 7 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #2246

    marcusr
    Participant

    I have copied the example that is posted on the FAQ section and got it working on the test environment of the bridge, but in production i get the response message ‘https authentication is required’. Any idea what is missing to get this working ?

    Regards,

    Marcus

    #2281

    Alfred
    Moderator

    No, I have no idea what is missing.

    You can run curl with the additional option –verbose to get more details.

    Instead of using curl and the internal SOAP interface (which can change with new releases) you can use the supported command line interface to the Bridge. As prerequisite you have to install Node.js.

    #2282

    marcusr
    Participant

    I have found the problem with the curl.
    If i start the url https://msappsrv03.msmode.lan:8080/bridge/BridgeManager in an explorer on the testserver and use the credentials admin:0DPiKuNIrrVmD8IUCuw1hQxNqZc= from the example provided in the FAQ, i get a logon screen. i can logon using admin:admin also like in the example. When i want to do the same in production the url https://msprodsrv01.msmode.lan:8080/bridge/BridgeManager returns an error 401.
    I believe the admin:0DPiKuNIrrVmD8IUCuw1hQxNqZc= is not sufficient for production.
    Could someone please resolve this ?
    Regards,
    Marcus

    #2283

    Alfred
    Moderator

    You find the password from your system in the file e2e_bridge_data/servlets/conf/tomcat-users.xml.

    <?xml version=’1.0′ encoding=’utf-8′?>
    <tomcat-users>
    <user username=”admin” password=”xyz” roles=”admin”/>
    </tomcat-users>

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.